Cynosure.X International LLC

:

Add Comment | Related Links | TrackBack
Related Content

NUL Missing on WinFLP

Recently, I have been playing with Windows Fundamentals for Legacy PCs (WinFLP). And I have found that even though WinFLP thinks NUL exists, it actually doesn't exist(unlike Windows XP). So it's been breaking my batch scripts. The following is the error message from using the NUL device on WinFLP.

C:\>echo > nul
The system cannot find the file specified.

C:\>echo > NUL
The system cannot find the file specified.

NUL is still a special device in WinFLP, becuase it certainly won't let you create or write to a "nul" file, therefore, producing the error message above. Question, is there a way to get the NUL device to work on WinFLP? Is there something that we can install?

Chieh Cheng
Fri, 11 Jul 2008 22:00:02 +0000

After doing some more digging, I found that "%systemroot%\system32\drivers\null.sys" is missing on WinFLP, while it exists on Windows XP. Could this have to do with the missing NUL problem? I search through the Windows XP registry but didn't find anything related to null.sys. I wonder if it is possible to install null.sys on WinFLP.

Chieh Cheng
Wed, 16 Jul 2008 22:47:49 +0000

I've been attacking this same problem for months now myself. While I love the minimalist nature of FLP, the lack of a proper NULL.sys means I can't really use it as a server.

I think that's what MS was thinking all along, to prevent FLP from being used that way.

Chuck Reed
Tue, 05 Aug 2008 02:32:35 +0000

Ok, I came across this web page: Windows Fundamentals for Legacy PCs

It explains how to get NULL to work on WinFLP. I haven't tried it myself yet. But it looks extremely promising!!! Will be trying it as soon as possible.

P.S. Funny thing, that web page is on the "Tao of Mac" web site!

Chieh Cheng
Mon, 06 Oct 2008 08:20:47 +0000

Hahah! I knew it was possible!

Thanks to whoever made this!

Chuck Reed
Mon, 13 Oct 2008 10:04:19 +0000

I can't make it work. The null device, as far as my system is concerned, is still non-existent.

Could it be because I updated to SP3 before installing it? Have you had any luck with it?

Chuck Reed
Wed, 15 Oct 2008 08:49:34 +0000

I figured out what I did wrong.

When I first installed it, I accidentally copied null.sys into the wrong directory. When FLP restarted, it looked for the null.sys, failed to find it, and apparently marked the driver as "invalid".

Anyway, all I had to do was go back through, delete all the regstry keys that that .reg file added, and restart. Then I went back through the installation process again. Works just great.

Now I have a lightweight web server!

Thanks again for providing this resource.

Chuck Reed
Wed, 15 Oct 2008 09:33:15 +0000

That's excellent, Chuck!!! I love hearing good news like this. Because I've been thinking about installing a light-weight web server on WinFLP. The last time I tried running Apache, it crashes on start up. I am so happy to hear that NUL works!

Chieh Cheng
Wed, 15 Oct 2008 16:37:14 +0000

Ok, I just followed the instruction and got NULL to work on WinFLP. That's a lot of work. So I'm going to automate the process for you guys. Attached below is the Null.reg file you need to apply to the registry. Download it, but don't apply it to your system. An installation batch file is coming next.

Attached File: Null.reg (1 KB)

Chieh Cheng
Mon, 20 Oct 2008 21:01:12 +0000

Ok, here is the installation batch file that will make your life easy. Download this file, download the Null.reg file from above, and put them into the same directory. Next, copy the following two files from your Microsoft Windows XP installation and put them in the same directory as the installation batch file.

  • \WINDOWS\system32\drivers\null.sys
  • \WINDOWS\system32\regini.exe

After you done that, just double-click on Install.bat and the NULL device driver will be installed for your WinFLP automatically. You'll just have to reboot for the change to take effect.

Attached File: Install.bat (1 KB)

Chieh Cheng
Mon, 20 Oct 2008 21:04:27 +0000

Chieh Cheng, you're my hero. I love you. This problem frustated the hell out of me. Where can I donate? :P

I'm gonna drink a beer for your health,
Cheers,

Thomas van der Ploeg

Thomas van der Ploeg
Tue, 23 Dec 2008 21:27:35 +0000

cool dude =D

thanks very much!

Mr NULwhere man
Thu, 18 Jun 2009 00:32:21 +0000

thanks for this! saved my bacon. cheers!

ron wilson
Fri, 26 Mar 2010 18:03:43 +0000

The old link to the Tao of Mac website has expired (due to site redesign).
The article still exists tho but needs to be accessed via: http://the.taoofmac.com/space/com/Microsoft/Windows/FLP

Great find you guys, consider this thread an internet-essential.

vernes
Sun, 30 May 2010 08:59:46 +0000

I googled the question as to why I can't get Firefox under WinFLP to go into the Internet (though it does go into the router) and I ended up here. Why?

Curious
Wed, 04 Aug 2010 07:17:34 +0000

Probably because there are very little information (relative to everything else) on WinFLP on the Internet.

Chieh Cheng
Wed, 04 Aug 2010 15:29:31 +0000

Merci (from France) beaucoup pour cette solution

Sébastien
Fri, 21 Jan 2011 17:31:01 +0000

Thank you so much for this solution! Greetings from Czech Republic.

fikus-kukis
Sat, 07 May 2011 10:09:39 +0000

Thank you very much!
You are the best!!!

so long!

Ben
Mon, 08 Aug 2011 19:11:40 +0000

This was a brilliant solution to a problem I had on dumb terminal PCs with an embedded operating system. It saved delaying a major software upgrade rollout. Thanks!!!!!

Gaz
Sun, 04 Mar 2012 23:19:26 +0300

Add Comment | Related Links | TrackBack
Related Content

Did your message disappear? Read the Forums FAQ.

TrackBack

Send Ping | TrackBack URL | Spam Control

Title: HasNUL.bat (GPL)
Weblog: Cynosure.X International
Excerpt: After finding out that Windows Fundamentals for Legacy PCs (WinFLP) does not have the NUL device, I decided to write this batch file to determine whether NUL device exists on any given Windows installation. You can use this script in your own custom script to make your script smarter and void the mi . . .
Tracked: Wed, 16 Jul 2008 23:20:01 +0000

Title: Can't Run an Application on WinFLP
Weblog: Cynosure.X International
Excerpt: Hi everybody, I installed win flp and it absolutely flies! I love it. I added the null.sys but I still can't run one program, a sophisticated subtitling application. It uses a sentinel dongle which is recognized and installed, but when I start the application it gives me an error and shuts down. Doe . . .
Tracked: Wed, 09 Jun 2010 16:56:51 +0000

Add Comment

Spam Control | * indicates required field
Your Name: *
E-mail:
Remember Me!
Comment: *
File attachment is optional. Please do not attach a file to your submission unless it is relevent.
Attach File:
(20 MB Max)
Spam Protection: * Answer of 9 - 2?
Click button only once, please!

Messages, files, and images copyright by respective owners.

Products | Services
Forums | Latest | RSS
Library | Search | Wiki
Help | Licenses

Login | Register

14 Users Online

Hacking Digital Cameras
Fun for Photographers


Amazon Associate


Copyright © 1996 - 2017. All Rights Reserved.